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Overview

The Plexon SoftServer is a special version of the MAP server that emulates the operation of the Harvey Box.  It provides the ability for the user to inject spike waveforms, events, and slow analog data.  SoftServer is especially useful for testing client applications. 
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There are three main modes of operation of SoftServer:
1. Generating artificial spike trains. This is useful when testing clients and you would like a stable, repeatable pattern of spikes. See the Generating Spike Trains section below.
2. Playing back a PLX file. This is useful when testing clients under more ‘real world’ situations. SoftServer will simply emit all data contained in the PLX file (spikes, continuous data, and events), as if it was produced by a real MAP system. It is not necessary to use SortClient to start and configure the flow of data in this case (In fact, using SortClient while playing back PLX files can be very confusing.) See the Playing Back PLX/DDT Files section below.

3. Playing back a DDT file. This is most useful for training and demonstrating SortClient. In this mode, SoftServer will emulate changing the gain and thresholding the continuous DDT data to form spikes. Note that using SortClient is effectively required when playing back DDT files (as the gain and thresholds must be set before spikes will be produced).

Installation

You can simply copy the file SoftServer.exe to a directory (e.g. \Rasputin) and double-click SoftServer.exe to start the program. For any questions about using SoftServer, please feel free to contact Dave Schmid at dave@plexoninc.com.
Quick Start
The SoftServer is an invaluable tool when using the Plexon client development kits to create your own custom client applications.  You can initially develop and debug your client application without the need for any hardware and then when all of the major functionality has been developed and debugged seamlessly switch over to the real MAP Server and test your custom application on real data.  
This section provides an overview of using the spike generation capability of the SoftServer to test the sample applications included in the Plexon client development kit.

The first step in debugging or testing a client application is to run SoftServer.  This invokes the SoftServer main dialog:
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Generating Spike Trains

This section demonstrates the procedure for generating spike waveforms.

Select the View > Generated Data Properties menu item:
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To invoke the Generated Data Properties Dialog:
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From the Generated Data Properties dialog, ensure the Generate Spike Waveforms option is selected in the Start Behavior area and then press the Properties button in the Spike Waveform Generation area to invoke the Spike Generator.
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From the spike generator dialog, press the Add button to add a spike train on the selected channel.  This brings up the Spike Train dialog to allow the user to select both a waveform for the spike train and to specify its activity characteristics.
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This dialog lets the user specify the waveform and activity characteristics for the spike train.  To specify the waveform, click on Spike 0 in the horizontal list box and to specify the activity characteristics, enter a value for the interval and offset.  For the first spike train, we leave the interval to the default of 20 ms.

Repeat this process to add an additional spike train with an interval of 27 ms.  The Spike Generator dialog now shows two spike trains for channel 1:
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SoftServer is now generating two unsorted spike trains on channel 1.  
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The generated spikes are not being sorted.  If your client application requires the spikes to be sorted, then you will have to invoke SortClient to sort them.  However, if your client application does not need the spikes to be sorted, you can run and test your client application without having to bring up SortClient.

To sort the generated spikes, run the Sort Client and press the Start: 
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The two generated spike trains show up on channel 1.  The waveforms corresponding to the spike trains are white indicating that they have not been sorted.  Next we use SortClient to sort the waveforms.  Note that SortClient actually sends the sorting parameters to SoftServer and SoftServer emulates the sorting normally carried out by the MAP hardware.  As shown below we can see both waveforms.  The spikes of the first spike train are sorted as Unit 01 and the spikes of the second spike train are sorted as Unit 02.
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Generating Continuous A/D Data

This section demonstrates the procedure for generating continuous data.

Select the View > Options Properties menu item:
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Select the NIDAQ options tab:
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From this properties page:

· Check the Enable NIDAQ box to enable the generation of continuous A/D data

· Select 1 for the Number of NIDAQ cards
· Select 16 for the A/D Channels per Card
· Select 40 KHz for the MAP Timing Board (TIM) Clock Frequency
Press the OK button.  

By default, Soft Server generates data for the first continuous channel (AD01) with a NI Gain of 100 and a sampling frequency of 1KHz.  
If your client application requires a different configuration (more channels or different parameters) then you will need to use Sort Client.  For example, to change the sampling rate from 1KHz to 2KHz: switch to Sort Client and click the Analog Channels tab.  Enable channel AD01 by checking the box in the Enable column, enter 2000 for the A/D Frequency and set the NI Gain to 100.  Press the Update Server button.
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Go to the Sort Client’s activity display.  The activity display shows the two generated spike trains and the continuous A/D channel:
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SortClient automatically starts with the last Server used:  MAP Server or SoftServer.  If you use SoftServer and want to switch back to MAP Server to access the real hardware, you will need to manually start the MAP Server before running SortClient.  Similarly, if you want to switch from using MAP Server to SoftServer, you will need to manually run SoftServer before running SortClient.
Playing Back PLX/DDT Files
This section demonstrates the procedure for playing back PLX and DDT files.

To play back a PLX file:
1. Press the File… button and select a PLX file. Note that this will change the number of channels and other parameters such as waveform width to be that of the PLX file.

If you repeatedly use the same PLX file while testing your clients, you can configure SoftServer to automatically complete this step by selecting ‘Use Last PLX/DDT File’ in the ‘Startup Behavior’ section of the ‘Generated Data Properties’ dialog. SoftServer will then load the last PLX file used when it is started.

2. Press Start to start the flow of data. 

3. By default, spikes from the PLX file will be played back with the sorted unit number that they had in the PLX file. It is possible to use SortClient to set up sorting and have SoftServer re-sort the data. Check the ‘Re-Sort Spikes From PLX Files’ checkbox on the ‘Generated Data Properties’ dialog box. However, see the caveats below.

Caveats:

Whenever you load a different PLX file, you should stop and restart SoftServer and all clients. This is because some client software (notably SortClient) does not respond well to having certain parameters change (like number of channels) out from underneath it.

For a similar reason, it can be confusing to use SortClient at all when playing back PLX files. There are some things that must be determined from the data in the PLX file (e.g. waveform widths, gains, thresholds) and not by the SortClient user interface. Changing these parameters in SortClient will have no effect. Worse, SortClient generally believes that “units do not exist until I create them”. When playing back a PLX file, units appear in the data that SortClient does not know about, and so the user interface does not display them properly.
To play back a DDT file:
1. Press the File… button and select a DDT file. Note that this will change the number of channels to be that of the DDT file.

If you repeatedly use the same DDT file, you can configure SoftServer to automatically complete this step by selecting ‘Use Last PLX/DDT File’ in the ‘Startup Behavior’ section of the ‘Generated Data Properties’ dialog. SoftServer will then load the last DDT file used when it is started.

2. Start SortClient. Press the Start button in SortClient. Use the normal techniques (possibly including the auto-configuration features) to adjust the gain and thresholds on the spike channels and sort them.   

3. If desired, enable some Analog Channels in SortClient. SoftServer can play the raw continuous data from the DDT file back as Analog Channels.

Caveats:

Whenever you load a different DDT file, you should stop and restart SoftServer and all clients. This is because some client software (notably SortClient) does not respond well to having certain parameters change (like number of channels) out from underneath it.

The ADC values from the DDT file are scaled by a factor of gain/5000 for spike channels, and gain/10 for slow channels. That is, setting a spike channel gain of 5000 (or 10 for slow channels) will result in the ADC values from the DDT file coming through unaltered. A gain of 10000 (20 for slow channels) will double the ADC values from the DDT file.

Although much more of the SortClient user interface appears to work as if a MAP system was present when playing a DDT file as compared with playing a PLX file, there are still limitations.

 

The following will not be supported by SoftServer:

- Throttling will not be supported, SoftServer has no concept of the active channel

- The MAP filter toggle will not be supported.

- Sterotrode/tetrode modes will not be supported

- No support for any start-recording mode except pushing the start recording button in SortClient

- No long spike waveforms.

- The spike channel digitization frequency must be 40Khz – you must use a DDT collected at 40Khz

- The slow channel digitization frequency must be 40Khz  – no decimation or filtering is being performed (yet)
1.       this means that the TIM freq must be set to 80 Khz in SoftServer

- No support for 16-bit DDT files

Running Sample Clients

Use SoftServer to generated data for the four sample clients.  See the documentation for the sample clients for details on their operation.
	[image: image14.png]- MFCSimpleRead  [X)

MAP averts





Simple Read


	[image: image15.png]£z MFCEventWait

MAP averts

poling te:





Event Wait

	[image: image16.png]£ MFCNIDAQRead
MAP events read

NIDAD (ACHO only)

Timestamp (sec)  Sample value

0000000 0
0001000 23
0002000 455
0003000 676
0004000 a8
0005000 1089
0005000 1276
0007000 1447





MFC NIDAQ Read


	[image: image17.png]£z MFCTimeStampR.... [X]

MAP averts

DSPOTa
DSPOTL
DSPOTe
DSPOTd
DSPI2Za
DSPOZb
DSPO2e
DSPO2d





MFC Time Stamp Read


SoftServer also provides a source of repeatable test data for your own custom client applications. 
Reference

The main display of the SoftServer is similar to the real Plexon MAP Server:
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The area below the menu displays information about the simulated data transfers rates between the PC and the simulated MAP box:

kw/s: kilowords transferred per second (16-bit words)

ts/s: time stamps per second

wf/s: waveforms per second 

MMF: Memory Map File – shows activity in the buffer used to distribute data from the MAP to the RASPUTIN clients.

NI: bandwidth of the continuous signals digitized by the NI DAQ device in kilosamples per second

Cmds: number of commands waiting to be sent to the MAP box (N/A for SoftServer)
Dropped waveforms: number of spikes (timestamps and waveforms) lost due to errors of data-transfer rate limitations;  this value is 0 (zero) under normal conditions. (N/A for SoftServer)
Clear button clears the information in the list box at the bottom of the display.
Clients connected: provides a count of the number of clients that are connected to the SoftServer.

The lower list box displays status information.

SoftServer Menus

There are four SoftServer menus:
· File

· View

· Data

· Help

File: The File menu contains two commands:  Playback File and Exit.
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View: The View menu contains three commands: Generated Data Properties, Hardware Configuration, and Options.
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Data: The Data menu contains three commands:  Start Data Pump, Stop Data Pump, and Inject Event.
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Help: The Help menu contains only the About Server command.
Menu Commands

The following sections provide information about the menu commands.
File > Playback File

Use the Playback File command to load a PLX or DDT file for playback.
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File Exit Command
Use the Exit command to shut down the SoftServer.

View Generated Data Properties Dialog
Use the Generated Data Properties command to invoke the Generated Data Properties Dialog.  
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Startup Behavior
Selects one of the two startup behaviors for SoftServer:  PLX/DDT Playback and Spike Waveform generation.
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File Playback
The File Playback area controls the startup behavior when the Use Last PLX/DDT File radio button is selected.
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File: displays the name of the PLX file selected for playback.
Loop: determines if the PLX file should be replayed when the end is reached.
Playback Rate:  specifies the playback rate as a ratio of real-time.
Re-Sort Data From File:  determines if the spike data should be re-sorted upon playback. Otherwise, it is presented with the sorting stored in the PLX file
Spike Waveform Generation 
Press the Properties button invokes the Spike Waveform Generation dialog:
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The Spike Generator dialog allows the user to inject one or more programmable spike trains on a selected channel.
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Channel: Selects the channel of interest.
Add:  Press the Add button to add a spike train to the selected channel.

Delete:  Press the Delete button to delete the selected spike train.
Edit: Press the Edit button to edit the selected spike train.

Copy:  Press the Copy button to copy the selected spike train to all of the other channels. 

Done: Press the done button to exit the spike generator.
Spike Train Option Dialog

The Spike Train options dialog is invoked when a new spike train is added to a channel or when a selected spike train is edited.  

Spike Train Waveform options
The waveform options tab allows the user to select the waveform shape for the spike train:
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Import:  Press the Import button to import more waveforms from a TPL file which is a file created by the Offline Sorter application to store sorting criteria.

Delete:  Press the Delete button to delete the currently selected waveform.

Spike Train Activity options
The Activity options tab allows the user to select the waveform period and offset of the spike train:
[image: image29.png]Spike Train

Waveforms  Activity

Interval (5)

Offset (3}





Interval (s):  Specifies the period of the waveforms in the spike train in seconds.
Offset (s):  Specifies offset of the first spike in train from the beginning of the experiment.

The Interval and Offset parameters specify the activity characteristics of the spike train:
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Select the intervals and offsets for the waveforms in a spike train so they don’t always coincide with each other.  For example, specify different offsets and/or intervals for each waveform in a spike train.
View Hardware Configuration

The hardware configuration command invokes the Box Configuration dialog.  The Box Configuration dialog allows the user to select the number of spike channels to be simulated.  The number of spike channels simulated is determined by the number of SIG and DSP boards activated.  Each SIG board handles 16 spike channels and each DSP board handles either 16 or 32 spike channels.  To add a SIG board, click on a “grayed” SIG slot and to add a DSP board, click on a “grayed” DSP slot.  For example to simulate 64 spike channels, you would need to activate 4 SIG boards and 2 DSP boards configured for 32 channels.  For the operation of this dialog see the RASPUTIN documentation for this command.
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View Options
The Options dialog box opens with the Box tab selected.
Options Box
The Box tab contains options that control the operation of the simulated MAP.
Gain Multiplier:  This field contains the gain multiplier.  See the RASPUTIN documentation for a more in depth description.

Size of the Memory-Mapped File (MB):  contains the size of the spike and waveform data in the circular memory buffer, which SoftServer makes available to the client programs; the default value is 8MB.
[image: image32.png]Options

b |wpaa|

Gain Mulpler:

Size of the Memory-Mapped File (MB): E





Options: NIDAQ 
The NIDAQ tab contains the settings for the NIDAQ device.
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Enable NIDAQ: Check this box to simulate the generation of continuous analog signals.

Number of NIDAQ cards: number of NIDAQ cards: 1, 2, 3, or 4.
A/D Channels per card: number of A/D channels per NIDAQ card: 16 or 64. 

Map Timing Board (TIM) Clock Frequency: must be set to 80 KHz in order to get 40 KHz continuous A/D data.

Data > Start Data Pump
The Start Data Pump command starts the generation of simulated data for the clients.
Data > Stop Data Pump

The Stop Data Pump command stops the generation of simulated data for the clients.
Inject Event

The Inject Event command invokes the Inject Events dialog.  This dialog is used to inject non-strobed events on a specified channel.
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